概要

Fumy RSS & Atom Maker Ver 0.972β
オンラインヘルプ 2009年06月08日版
概要

Fumy RSS & Atom Maker Ver 0.972β

はじめに

メインウインドウ（サムネイル） 「Fumy RSS & Atom Maker」をダウンロードいただき、ありがとうございます。
このソフトウェアは、HDD内にある特定フォルダの中にあるファイルを走査し、最近に更新されたファイルの情報のRSSフィードやAtomフィードを生成するソフトウェアです。

RSS・Atomフィードは、ブログなどのシステムを使わないと容易には生成できませんが、このソフトウェアを使えば、RSS・Atomフィードを簡単に自動生成することができます。

ブログなどのシステムを利用せず、自力でHTMLを記述しているホームページでも、手軽にRSS・Atomフィードを公開することができるようになります。 また、設定次第では、HTMLファイル以外のファイルのRSS・Atomフィードを生成することもできますので、最近追加された画像のRSS・Atomフィードを生成する用途にも活用できます。

内蔵のFTP機能を使えば、手軽にサーバにRSS・Atomファイルをアップロードすることもできます。 さらに、Update Ping 送信機能も内蔵しているため、各Pingサーバに手軽に Update Pingを送ることができます。

iTunes（iPod）に音楽を配信するPodcast(ポッドキャスト)用RSS2.0フィードの作成を試験的にサポートしています。 MP3ファイルなどの音楽ファイルを対象にRSS2.0形式で出力すると、（必要最低限の）Podcast用XML要素を出力できます。
また、検索エンジン向けのサイトマップファイル（Sitemap XML）の出力を試験的にサポートしています。

機能と特徴
  • ローカルHDD内にあるファイルから、RSSフィードやAtomフィードを生成。
  • ファイルの中身から、自動的にフィードに含める情報を抽出。
  • 自動的に抽出する方法は、ユーザが設定可能。
  • 特定のファイルを対象から除外可能。
  • フィードに含める情報は設定で選択が可能。
  • HTMLファイルに限定せず、様々な形式のファイルからRSSフィードやAtomフィードを生成可能。
  • FTP機能を内蔵しているので、作成したRSSファイルを直接サーバへアップロード可能。
  • Update Ping送信機能を内蔵しているので、Pingサーバに手軽にUpdate Pingを送信可能。
  • RSS・Atomフィードは、SHIFT-JISコードまたは UTF-8コードで出力可能。
  • 読み込むファイルは、SHIFT-JIS・EUC-JP・UTF-8をサポート。
  • Podcast（ポッドキャスト）用RSS2.0フィードの作成を試験サポート。
  • Sitemap XML（サイトマップファイル）の作成を試験サポート。
  • ボタンクリック（もしくはソフトウェアを起動するだけ）で、情報抽出～RSS作成～アップロードまで、すべての作業を全自動で実行できる機能も搭載。
  • 各ボタンなどには極力ツールチップで説明を表示するように設計。

操作マニュアル
  1. 操作の流れ
  2. 初回起動時・新規プロジェクト作成
  3. メインウインドウの説明
  4. ウェブサイトに関する基本情報を設定する
  5. RSS/Atomフィードに関する詳細設定
  6. 動作設定（表示に関する設定）
  7. FTP機能を使う
  8. Update Ping送信機能を使う
  9. Podcast（ポッドキャスト）用RSSを出力するには
  10. 全自動作成機能を使う（おすすめ！）
  11. 試験実装機能について（Sitemap XMLの出力など）
◆また、操作手順に関する簡単な説明は、以下のページでも行っています。(Ver 0.40当時の説明)
http://allabout.co.jp/internet/hpcreate/closeup/CU20051111A/

バージョンアップ情報

Ver 0.971β → Ver 0.972β
  • 制限文字数の解釈ミスを修正
    ある条件下において、制限文字数の指定が正しく解釈されず、無条件に全文を含めてしまっていた問題を修正。（※指定文字数の最後の位置にある文字が2バイト文字ではなかった場合に、無条件に全文を含めていました。）
  • サイトマップファイル（Sitemap XML）の出力機能を改良
    グリッドに表示されている全ファイルを対象に出力していたのを、RSSの出力対象に指定されているファイルだけに限定して出力できるよう仕様を変更。除外設定されたファイルや、指定制限数を超えたファイルは、XMLに含まないようにしました。（全ファイルを対象に出力させたい場合は、一時的に出力対象数の設定を増やして下さい。）
Ver 0.97β → Ver 0.971β
  • 一度も「出力設定」ウインドウを開かないままRSSを生成すると、文法的に問題のあるフィードになってしまう不具合を修正。
Ver 0.96β → Ver 0.97β
  • サイトマップファイル（Sitemap XML）の出力を試験サポート。（メニューの「データ」→「グリッド操作」→「Sitemap XMLに出力」で実行）
Ver 0.95β → Ver 0.96β
  • FTP機能の微修正
    アップロード先ディレクトリの設定に関して微修正を行いました。
  • デフォルトの設定を一部変更
    新規プロジェクトのデフォルト設定内容を一部変更しました。
  • 注釈の追加
    設定ウインドウ中に、操作ガイド(注釈)を追加しました。
Ver 0.94β → Ver 0.95β
  • ローカル文字コードの強制解釈機能をサポート
    ローカルファイルの文字コードを、自動判別させずに強制的に設定できるようになりました。これにより、自動判別が失敗して文字化けしてしまうような場合は、自ら「SHIFT-JIS」や「UTF-8」などに設定することで、文字化けを回避できます。（設定は「サイト設定」の「ファイル・フォルダ」から。）
    ※UTF-8コードのファイルを確実に自動判別させるには、BOM（Byte Order Mark）を付加して下さい。ファイルの先頭にBOM（EF・BB・BF）を発見した場合は確実にUTF-8であると解釈します。
  • Contentモジュールをデフォルトで使用するよう変更
    RSSのデフォルト設定でもContentモジュールを利用するように変更しました。（既存の設定内容は変更しません。）
Ver 0.93β → Ver 0.94β
  • Pingサーバからのレスポンスを個別に保存可能に
    Update Pingの送信時に、Pingサーバからのレスポンスをサーバ別にXMLファ イルとして自動保存ができるようになりました。（※この機能は、標準では「OFF」に設定されています。「サイト設定」の「Ping」項目から設定できます。）
  • Pingサーバのタイムアウト時間の保存処理を修正
    Update Ping送信時のタイムアウト時間を、「サイト設定」ウインドウ上で変更しても保存されなかった問題を修正しました。
Ver 0.92β → Ver 0.93β
  • 半角「&」記号を二重にエスケープしてしまう問題を修正
    半角「&」記号は実体参照に変換しますが、元々実体参照で記述されているものも含めて二重に変換してしまっていた問題を修正しました。
  • 新規作成ウィザードの記載文章にミスがあった点を修正
Ver 0.91β → Ver 0.92β
  • ある条件下でAtomフィードが文法的にうまく生成できない問題を解決
    Atomフィード生成時に、抽出文字列によってはsummary要素の内容が、XMLの文法違反になってしまう問題を解決。
  • RSS作成インターフェイスを改善
    インターフェイスの一部を微調整しました。
Ver 0.90β → Ver 0.91β
  • Atomフィードに含める作成日付項目を選択可能に
    Atomフィード中の「created」要素と「issued」要素にファイルの作成日時ではなく更新日時を格納できるオプションを追加しました。これによって、「作成日付（created要素）」をチェックするRSSリーダーに対して更新日を作成日のように見せることができます。（ただし、標準設定のままでは「ファイルの作成日時」が使われます。設定は「出力設定」のAtom項目で変更できます。）
  • 全自動実行処理中の表示を改善
    全自動実行中に、進行状況の一部が見えない可能性がある点を修正しました。
Ver 0.87β → Ver 0.90β
  • 情報抽出処理の改良
    設定した方法で1文字も抽出できなかった場合は、自動的に他の方法を試してなんとか何らかの文字を抽出するように改良しました。
  • ファイル名に「&」記号が含まれる場合の問題を修正
    ファイル名に半角「&」記号があって、タイトルとしてファイル名がそのまま採用された場合に、XMLの文法的に誤ったRSS/Atomフィードが生成されていた問題を解決しました。（「%26」にエスケープします。）
  • 「&」「"」「<」「>」の各記号が含まれる場合に実体参照に変換するよう修正
    タイトルやジャンルにこれらの文字が含まれる場合、そのままフィードに含めるとXMLの文法上エラーになるので、実体参照に変換して含めるよう修正しました。
  • タイトルやジャンル内に含まれる改行を削除するよう修正
    タイトルやジャンルに改行が含まれる場合、改行文字を削除してフィードを生成するよう修正しました。
  • 設定のアップデートチェック機能の追加
    古い形式の設定ファイルが読み込まれた場合に、アップデートを促すメッセージをウインドウ下部に表示するよう改良しました。
  • その他
    そのほか、細かな微調整・微修正を行いました。
Ver 0.86β → Ver 0.87β
  • RSS/Atom生成画面でもフィードに含める順序を変更できるように改良
    情報抽出後、RSS/Atomフィード生成画面で、固定追加ファイルも含めてフィードへの掲載順序を自由に修正できるようにしました。
  • 内容抽出の際、空行は詰めるよう改良
    抽出したページ内容に空行が含まれる場合は、自動的に行を詰めるよう修正しました。
Ver 0.85β → Ver 0.86β
  • 固定追加ファイルの更新日時情報を修正
    固定追加ファイルの更新日時が正しく取得できていなかった問題を修正。（更新日時ではなくアクセス日時を取得していました。）
  • 固定追加ファイルの更新日時情報の機能追加
    実際のファイルの更新日時を使用するほか、RSS作成時の日時を採用することもできるようにしました。これによって固定追加ファイルが「たった今、更新されたように見せる」ことができます。
  • その他、細かな修正・改良を行いました。
Ver 0.80β → Ver 0.85β
  • 新規作成・開く・保存の各インターフェイスを改良
    新しくプロジェクトを作成するダイアログが分かりにくかったので、ウィザード形式に変更しました。開くダイアログも分かりにくかったので、プロジェクトを開く版と設定ファイルの組み合わせを指定して開く版に分割して、分かりやすくしました。保存ダイアログの表示動作に分かりにくい点があったので修正しました。
Ver 0.77β → Ver 0.80β
  • FTP処理からPing処理へ移動する際にフリーズする環境に対処
    一部の環境では、FTP処理の直後にPing処理を行おうとすると、フリーズしてしまう場合がありました。その問題に試験的に対処しました。
Ver 0.76β → Ver 0.77β
  • 全自動実行処理中のFTP処理でエラーが出ても中断しないよう改善
    全自動実行処理中にFTPエラーが発生すると、問答無用で全自動実行を中断していた仕様を、中断するか続行するかユーザに質問するように変更しました。(FTPエラーが発生しても、アップロードが完了しているようなら、そのまま処理を続行させ、Ping送信を行っても問題ありません。)
Ver 0.75β → Ver 0.76β
  • Ping送信機能のタイムアウト設定をサポート
    Pingサーバと通信する際のタイムアウト時間の設定を保存できるようにしました。「サイト設定」の「Ping」項目から設定できます。また、Ping送信ウインドウを見やすく整理しました。ここからも一時的に設定を変更できます。
  • ファイルリストのCSV出力機能を追加
    メイン画面に表示されているグリッド内の情報をCSV形式で出力できる機能を加えました。更新日時順に整列したファイルリストが必要な場面に多目的にご活用頂けます。保存するには、グリッド内を右クリックしてメニューから「グリッドの内容をCSVに保存」を選択してください。メインメニューの「データ」→「グリッド操作」→「CSVに出力」でも可能です。
Ver 0.74β → Ver 0.75β
  • 連携テキストエディタを自由に指定可能に
    ファイルリストなどから対象ファイルをテキストエディタで読み込む際、メモ帳以外の任意のテキストエディタも使えるようにしました。「動作設定」で任意のテキストエディタを指定できます。これによって、使い慣れたテキストエディタを呼び出すことができるようになります。
Ver 0.73β → Ver 0.74β
  • ファイル名に含まれる空白文字をエスケープするよう修正
    ファイル名に空白文字が含まれる場合、生成URLには空白文字を「%20」にエスケープするよう修正しました。これによって、Podcastなどで発生する問題がなくなります。
Ver 0.72β → Ver 0.73β
  • 固定追加ファイルの二重掲載を防止
    固定追加ファイルに指定しているファイルが最近に更新されている場合、同じページが重複してRSS/Atomフィードに含まれてしまう問題を修正しました。
Ver 0.71β → Ver 0.72β
  • 除外ファイルの指定方法に「正規表現」をサポート
    RSS/Atomフィードに含めたくないファイル「除外ファイル」を指定する方法として、正規表現による指定をサポートしました。
    これにより、正規表現を用いて「 sample[a-z0-9]*\.html 」などという方法で除外ファイルを指定可能になりました。
Ver 0.70β → Ver 0.71β
  • デフォルトファイル名を省略したURL表記をサポート
    index.htmlなど、ファイル名を省略してもアクセス可能なファイルに対しては、ファイル名を省略した状態のURLを掲載できるようになりました。
    ※標準ではOFFです。（出力設定の「URL」ページで、この機能をONにできます。）

    例えば、通常「 http://www.nishishi.com/index.html 」となるファイルに対して「 http://www.nishishi.com/ 」というURLを掲載するようにできます。
Ver 0.69β → Ver 0.70β
  • ファイル名やフォルダ名に日本語文字が使われている場合の問題を修正
    ファイル名に「表示」や「ソース」などの文字コード「5C」を含む文字が使われている場合に、URLが文字化けしてしまう問題を修正しました。
  • ファイルからの情報抽出方法を拡張
    各ファイルからの情報抽出処理で、「概要」と「エントリ内容」に関しては設定されている方法で何も情報が抽出できなかった場合に、自動的に他の方法を使って情報抽出を試みるように拡張しました。
Ver 0.68β → Ver 0.69β
  • ウインドウの表示位置としてマイナスの座標を許容する設定を追加
    マルチディスプレイなどで、ウインドウの表示座標がマイナスになる場合でもそのまま表示させられる設定を追加しました。（従来は、マイナスの座標に表示しようとした場合、強制的に原点(0,0)に戻すようになっていました。）
  • ウインドウサイズが小さい場合にツールバーが表示されなくなる不具合を修正
    ウインドウサイズが非常に小さい状態で起動したとき、ツールバーの半分がまったく表示されなくなる不具合を修正しました。
Ver 0.67β → Ver 0.68β
  • 全自動実行の完了後、アプリケーションを自動で終了するオプション
    「/Auto」パラメータを使用してアプリケーションを起動して、全自動実行を行った際、すべての作業を完了した後にアプリケーションを自動終了するためのパラメータ「 /Exit 」を加えました。（※詳しくはマニュアル「全自動作成機能を使う」ページをご参照下さい。）
  • Update Ping送信時のタイムアウト時間を指定可能に（試験実装）
    Update Ping の実行ウインドウで、Pingサーバからの返事を待つタイムアウト時間を任意に指定できるようにしました。（現行バージョンでは、変更した値は保存されません。）
Ver 0.66β → Ver 0.67β
  • 抽出した本文(Content)の各行頭・行末に含まれる空白を削除
    RSS/Atomフィードに本文を含むようにした場合、抽出元のHTMLファイルによっては、各行の行頭や行末に無駄な空白が含まれる場合がありました。それらの無駄な空白を自動的に削除するようにしました。（行の端ではなく途中にある連続した空白はそのままです。）
    ※概要やタイトルの場合は、従来から前後の無駄な空白は自動削除していました。
Ver 0.65β → Ver 0.66β
  • 除外規則の指定方法として「部分一致」と「ファイル名完全一致」をサポート
    → RSS/Atomフィードに含まないようにするるファイルの指定方法として、従来の「フォルダを指定する」方法のほか、「任意の文字列を含むパス」を除外する方法や、「特定の文字列に完全一致するファイル」を除外する方法を追加しました。
Ver 0.63β → Ver 0.65β
  • RSS/Atomフィード自身の更新時刻を含める
    → RSS/Atomフィードに、自分自身の更新時刻も書き込むようにしました。
  • サンプルXSLTファイルの提供
    → RSS/Atomフィードに指定するスタイルシート（XSLTファイル）のサンプルを同梱しました。これらのファイルをアップロードし、「出力設定」からXSLTを使用するように設定すれば、XSLTを使った表示ができるようになります。
  • 除外規則の設定に関する不具合の対策
    → 不具合発生時に、除外規則の読み込み状況を確認できる表示を追加しました。
Ver 0.62β → Ver 0.63β
  • FTPのタイムアウト時間を指定可能に
    → FTPのタイムアウト時間を自由に指定できるようにしました。また、Passiveモードの設定やタイムアウトの設定を保存するようにしました。
  • 不具合の修正とインターフェイスの改良
    → 除外フォルダリストから設定項目を削除する際、確認ダイアログの表示が誤っていた問題を修正しました。また、固定追加ファイルの設定画面を見やすく改良しました。(ちょっとだけ)
Ver 0.61β → Ver 0.62β
  • 除外フォルダの指定機能の改良
    → 特定のフォルダをRSS作成対象から除外する機能で、除外フォルダの選択を行いやすいよう改良しました。
  • HTMLタグ除外処理のバグ修正
    → RSS/Atomフィードに含める文字列の中から、HTMLタグを除外する処理中に、問題がないのにもかかわらずエラーメッセージが表示されてしまう問題を解決しました。また、タグを表す記号が連続して現れる場合（同じ記号が連続して現れる場合のみ）に、解析が失敗してエラーになってしまう問題を解決しました。
Ver 0.60β → Ver 0.61β
  • ファイルのドラッグ＆ドロップをサポート
    → メインウインドウへファイルをドロップすることで、任意のファイルをリストに追加できるようにしました。（プロジェクトファイルをドロップした場合は、そのプロジェクトを読み込みます。）
  • 情報抽出時のログ表示抑制機能の搭載
    → RSS/Atomフィード用に情報を抽出している際に、SHIFTキーを押しっぱなしにしていると、コンソールへの進捗状況表示を抑制するようにしました。これによって、情報抽出時に発生するエラーを抑えられるかも知れません。（試験実装）
Ver 0.51β → Ver 0.60β
  • 全自動作成機能を搭載
    → ソフトウェアの起動と同時（もしくはボタンクリック時）に、情報抽出～RSS/Atomフィードの作成～FTPでのアップロード～PingサーバへのUpdate Pingの送信まで、すべての作業を（ユーザ無操作で）全自動で行う機能を搭載しました。
Ver 0.50β → Ver 0.51β
  • Podcast(ポッドキャスト)のサポート(試験)
    → iTunes（iPod）に音楽を配信するためのPodcast用RSSフィードの作成を試験的にサポートしました。対象ファイルリストに音楽ファイルや映像ファイルがあった場合、Podcast用RSSとして出力ができるようになりました。（現段階では、最低限の要素しかサポートしていません。）
Ver 0.40β2 → Ver 0.50β
  • Update Ping送信機能を搭載
    → 各Pingサーバに対して、Update Ping を送信できるようになりました。
Ver 0.40β → Ver 0.40β2
  • マニュアルを増強。（プログラムに変化なし）
Ver 0.30β → Ver 0.40β
  • 簡易FTP機能を搭載
    → 内蔵FTP機能を使って、RSS・Atomファイルをサーバへアップロードできるようになりました。
Ver 0.22β → Ver 0.30β
  • 除外フォルダの指定機能をサポート。
    → 特定のフォルダをRSS作成対象から除外する機能を実装しました。作業用フォルダやスクリプト用フォルダなど、更新されたファイルがあっても、RSSには含めたくないようなフォルダを指定しておくと便利です。
Ver 0.21β → Ver 0.22β
  • HTMLタグの除外機能をサポート。
    → 抽出された文字列中にHTMLタグが含まれていた場合、そのままRSSにHTMLタグを含めるか、もしくはタグを除外してプレーンテキストにしてから含めるかを選択できるようにしました。
  • Atom0.3で収録項目の選択項目を追加。
    → 「製作者情報」と「内容」を含めるかどうかを選択できるようにしました。
  • 文字数を限定した場合の不具合を修正。
    → 文字数を制限値まで切りつめた際、一部の場合に不正なコードが含まれてしまい、一部のブラウザで正しくXMLとして認識できなくなる問題を修正。
Ver 0.20β → Ver 0.21β
  • バグ修正（2件）・仕様修正（1件）
    • 標準設定の言語が「ja」ではなく「jp」になっていた点を修正。
    • 一度も「出力設定」ウインドウを開かないままRSSを作成すると、ヘッダがまったく出力されない状態で作成してしまう問題点を修正。
    • HTMLからの「内容(Content)」の抽出先の標準設定が body 要素だったのを p要素に変更。（body要素ではあまりにも範囲が広すぎるため）
Ver 0.10β → Ver 0.20β
  • 固定追加HTMLの登録機能をサポート。
    → 更新時刻に関係なく常にRSS・Atomフィードに特定のHTMLを含められるようになりました。
  • プロジェクトを開くダイアログの仕様修正。
    → プロジェクトを開くのか、各設定ファイルの組み合わせを開くのか、紛らわしかった表示を修正しました。
Ver 0.02β → Ver 0.10β
  • 「出力設定」内の各モジュール（Dublin Core, Syndication, Content）をサポート。
    → RSS・Atomフィードに含められる情報を細かく選択できるようになりました。
  • RSS2.0・Atom0.3のヘッダの見直し。
    → 不要なヘッダが生成されていたのを修正し、シンプルなフィードを出力できるようになりました。
  • 文字コード「UTF-8」のサポートを強化。
    → UTF-8で記述されたファイルをSHIFT-JISと誤ってしまう可能性がある問題点を解消しました。
  • 起動速度の向上。
    → 大量にファイルが存在するフォルダを指定したプロジェクトがあるとき、起動完了までに時間がかかる問題を解決しました。
Ver 0.01β → Ver 0.02β
  • 「出力設定」内の「最大文字数」の設定をサポート。
    → タイトルや概要の最大文字数を指定できるようにしました。
  • 「出力設定」内の「ヘッダ」の設定をサポート。
    → XML宣言の有無や、任意のXSLファイルの指定をできるようにしました。（ヘッダの文字列を自由に編集することもできます。）

免責・著作権情報

「Fumy RSS & Atom Maker」の著作権は、西村文宏（にしし）にあります。著作権所有者に許可なく、複製・改変・再配布を行うことを禁じます。
このソフトウェアを使用した結果、使用者がいかなる損害を被ったとしても、製作者及び公開者は、その責を一切負いません。 使用者個人の責任でご使用下さい。

なお、このソフトウェアを紹介する場合などで、このソフトウェアの画面イメージ（キャプチャ画像）は、製作者に許可なく自由に使用（掲載・転載・公開）して頂いて構いません。 （ソフトウェアそのものの転載は、著作権所有者に許可なく行うことはできません。）
雑誌への掲載・付録CD-ROMへの収録は歓迎します。詳しくは、README.TXT をご参照下さい。

連絡先
  • [サポート窓口] softsupport あっと nishishi.com ご意見・ご感想・ご要望、大歓迎です！
  • [送信フォーム] http://www.nishishi.com/sendmail.shtml （匿名での送信も可能です）
  • [製作者運営サイト] http://www.nishishi.com/
  • ※もし、上記のメールアドレスが不着になっていたり、上記サイトにアクセスできなくなっていた場合は、ベクター作者紹介ページ（にしし）内のリンクからたどってみて下さい。

「Fumy RSS & Atom Maker」の著作権は、西村文宏（にしし）が所有しています。
このヘルプファイルの文責は、西村文宏（にしし）にあります。
ソフトウェアに関するご質問・ご意見・ご感想などは、こちらの送信フォームまたはメールアドレスまでお送り下さい。
http://www.nishishi.com/


画面イメージ - Fumy RSS & Atom Maker マニュアル

Fumy RSS & Atom Maker Ver 0.62β
オンラインヘルプ 2006年01月05日版
概要 → 画面イメージ

画面イメージ （50％縮小）

Fumy RSS & Atom Maker Ver 0.62βの画面イメージです。
初回起動時のウインドウサイズは、ご使用のデスクトップの面積によって異なります。 例えば、1280×1024解像度のデスクトップの場合は、960×722で起動します。

画面イメージ
（画像クリックで拡大）

上記の画像をクリックすると、1280×1024解像度のデスクトップ上で実行した場合の原寸サイズ（960×722）を表示します。

戻る


操作の流れ

初回起動から初回使用までの、だいたいの操作の流れは下記の通りです。
（それぞれの機能の詳細については、このヘルプ内の各ページをご参照下さい。）

  1. 初回起動時　…データファイルの指定
  2. サイト設定　…必要最低限の設定
  3. RSS・Atomフィードの作成　…フィードを作成
  4. FTPでアップロード　…内蔵FTP機能でアップロード
  5. Update Pingを送信　…内蔵Ping送信機能で更新情報を送信

このページでは、上記の1～3の手順の概要を紹介しています。
詳しい使用方法は、このヘルプ内の各ページをご参照下さい。

初回起動時
1 | 新規プロジェクト作成ダイアログ | ＜新規プロジェクトの作成ダイアログ＞ 初回起動時は、自動的に各種設定ファイルの名称などを決定するダイアログが開きます。 いきなり詳しく設定することもできますが、「簡易セットアップ」を選択しておけば、すべて自動的に決定されますので、何も入力することなく設定が完了します。 「簡易セットアップ」をクリックして「次へ」ボタンをクリックし、最後に「完了」ボタンをクリックして下さい。
2 | 最初のメイン画面 | ＜メインウインドウ＞ この時点では、まだ、生成したいRSS・Atomフィードに含めるファイルがどこのフォルダにあるのかが設定されていないので、 ソフトウェアのあるフォルダ内のファイルリストが（更新時刻順に）並んで表示されています。

→ 初回設定について詳しい説明は、「初回起動時・新規プロジェクト作成」へ。

ここまでできたら、次は、「サイト設定」を行います。この作業をしないと、正確なRSS/Atomフィードが生成できませんので、必ず行って下さい。

サイト設定
1 「サイト設定」ボタン 「サイト設定」ボタンをクリックして、ホームページに関する基本情報の登録や、HTMLファイルからの情報の抽出方法を指定します。 この作業を行わないと、適切なRSS・Atomフィードは生成されません。
2 「サイト設定」画面／サイト情報登録 「サイト設定」画面では、最初に「サイト情報登録」タブが選択されています。
ここでは、RSS/Atomを生成する対象のホームページに関する情報を登録します。
  • タイトル　：　ホームページ名
  • URL　：　ホームページのURL
  • 概要　：　ホームページの紹介文
  • 言語　：　ホームページの言語（日本語の場合は jp を選択）
  • 著作権　：　著作権情報
上記の情報は、RSS/Atom内に含められます。これらはすべて必須項目ですので、必ず何か入力して下さい。
3 「サイト設定」画面／作者情報登録 次に、「作者情報登録」タブをクリックして、ホームページの製作者名などを登録します。
名前以外は、省略しても構いません。
  • 名前　：　製作者名
  • メール　：　連絡先メールアドレス
  • URL　：　連絡先URL
上記の情報は、RSS/Atom内に含められます。含めたくない項目は、空欄にしておいて下さい。なお、名前だけは必須ですので、何か入力して下さい。
4 「サイト設定」画面／ファイル・フォルダ設定 次に、「ファイル・フォルダ設定」タブをクリックして、ローカルやサーバのフォルダや、RSS/Atomの生成先に関する設定を行います。
この設定は非常に重要です。

【対象HTMLの場所】
  • ローカルフォルダ： RSS/Atomを生成したいHTMLファイルが存在するHDD上のフォルダを指定します。
    例： D:\Web\Server
  • サーバURL： 上記のフォルダに対応するサーバ上のURLを指定します。
    例： http://www.nishishi.com/
【出力先】
  • 各RSSフィードやAtomフィードの生成先フォルダとファイル名を指定します。
    上記の「ローカルフォルダ」を指定すると、自動的に決定されますが、他の場所に変更することもできます。
【文字コード】
  • サーバの文字コード： 出力するRSS/Atomファイルの文字コードを指定します。ここでは、SHIFT-JIS か UTF-8 が選択できます。（ここでの設定に関係なく、出力時に文字コードを変更することもできます。）
上記の情報は、RSS/Atom内に含められます。全項目必須です。必ず何か入力して下さい。
特に「サーバURL」は、正しく入力しないと、正しいファイルを指し示すRSS/Atomフィードが生成されませんので注意して下さい。
5 「サイト設定」画面／情報抽出方法の設定 次に、「情報抽出方法の設定」タブをクリックして、HTMLファイルから情報を自動抽出する方法を設定します。
ここでは、
  • ページタイトルの取得先
  • 概要（サマリー）の取得先
  • エントリー内容の取得先
  • ジャンルの取得先
…の4項目を自動的に取得するための設定ができます。
標準設定では、「ページタイトル」は、「title要素（ <title>～</title> ）」に記述されている文字列が抽出されるようになっています。 「概要」は、「meta要素のname属性がdescriptionであるcontent属性」に記述されている文字列が抽出されるようになっています。
どの要素（タグ）の情報を抽出するか、自由に設定可能です。
また、要素（タグ）以外の文字列に挟まれた内容を抽出するよう設定することもできます。
6 OKボタン すべての設定が完了したら、「OK」ボタンをクリックします。
すると、メインウインドウに戻り、今設定した内容が反映されます。（指定したフォルダ内にファイルが多い場合、処理に少し時間がかかりますので、そのまま待って下さい。）
5 サイト設定が完了した後のメインウインドウ メインウインドウに戻ると、「サイト設定」で指定した「ローカルフォルダ」内のすべてのファイルの一覧が、更新時刻の新しい順に並べ替えられて表示されます。 （サブフォルダの中に含まれるファイルもすべてリストアップされています。）

以上で、サイト設定は完了です。
最低限の設定は完了していますので、すぐに RSS/Atom フィードを生成することができます。

→ サイト設定について詳しい説明は、「ウェブサイトに関する基本情報を設定する」へ。

RSS/Atomフィードの生成
1 | RSS/Atom生成ボタン | RSSフィードまたはAtomフィードを生成するには、ツールバー上の「RSS1.0」ボタン・「RSS2.0」ボタン・「Atom0.3」ボタンのいずれかをクリックします。
2 | RSS生成中の画面 | すると、対象ファイルを読み込んで、自動的に情報を抽出します。 情報抽出処理中は、左図のような画面が出て、進行状況を表示します。 多くの場合、この画面が出るのは一瞬です。 ※特に見る必要はありませんが、情報の抽出がうまくいかなかった場合は、後からこの画面を参照することで、問題が発見できるかも知れません。
3 | 最初のメイン画面 | 情報の抽出が終わると、抽出結果が表示されます。 グリッドには、「対象ファイルのローカルパス」、「対象ファイルのURL」、「タイトル」、「概要」、「カテゴリ」、「更新日時」が表示されています。 各行をクリックすると、そのファイルから抽出した情報が、右側の「情報」領域に表示されます。 ただしく抽出できているかどうか確認して下さい。 なお、この右側の「情報」領域は、書き換えが可能です。ここで書き換えた内容がRSS/Atomフィードに使用されます。 （ここを書き換えても、オリジナルのHTMLファイルが書き換わることはありません。）
4 | 生成ボタン | ウインドウ下部の「RSS1.0を生成」または「RSS2.0を生成」または「Atom0.3を生成」ボタンをクリックすると、フィードが出力されます。
5 | 生成完了ダイアログ | 生成が完了すると、左図のようなダイアログが出ます。 緑色の下線が引かれている出力ファイル名をクリックすると、生成されたRSS/Atomフィードをブラウザで表示できます。 その他、エディタで開いたりフォルダを開いたりできます。
5 | 生成したRSSをブラウザで表示させたところ | （生成したRSSフィードをブラウザで表示させてみたところ）

以上で、RSS/Atomフィードの出力は完了です。あとは、生成したファイルをサーバにアップロードすれば、RSS/Atomフィードを公開できます。
内蔵のFTP機能を使えば、簡単にRSS/Atomフィードをアップロードすることができます。 詳しくは、「FTP機能を使う」をご参照下さい。

なお、RSS/Atomフィードをサーバに公開したら、RSS/Atomフィードを公開しているという情報を index.html などトップページのHTMLファイルに含めておきましょう。

<link rel="alternate" type="application/rss+xml" title="RSS 1.0" href="http://（RSS1.0のURL）" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://（RSS2.0のURL）" />
<link rel="alternate" type="application/atom+xml" title="Atom" href="http://（AtomフィードのURL）" />

…などのように、HTMLファイルのhead要素（<head>～</head>）に含めておくと、RSSリーダなどのソフトウェアが自動的にRSSファイルを発見できます。

RSS/Atomフィードを更新したことを、各Pingサーバに送信したい場合は、内蔵の Update Ping 送信機能を使えば簡単に行えます。 詳しくは、「Update Ping送信機能を使う」をご参照下さい。

その他の設定
* | ＜対象ファイル数＞ エントリ数の指定 | ＜対象ファイル数＞ RSS/Atomフィードに含めるファイル数（エントリ数）は、メインウインドウ上部の「収録数」項目で指定できます。 1以上の値であれば、いくらでも指定可能です。 ただし、「出力設定」で、RSSの種類別に「最大エントリ数」の設定が可能なので、その値よりも大きな数値を指定しても、 その最大エントリ数までしか出力されません。
* | ＜対象から一時的に外す＞ 対象から除外する指定 | ＜対象から一時的に外す＞ RSS・Atomフィードに含めたくないファイルがある場合は、その行を選択した状態で、ツールバーの「除外」ボタンをクリックするか、 キーボードから [Ctrl]＋[Del]キーを押します。すると、そのファイルは除外されます。 除外を取り消すには、再度同じ操作をします。
* | ＜対象拡張子の指定＞ 対象拡張子の指定 | ＜対象拡張子の指定＞ 標準では、すべてのファイルが対象になっていますので、画像ファイルやCGIファイルなどもRSS/Atomフィードに含んでしまいます。 それらを除外したい場合は、対象拡張子を限定して下さい。 メインウインドウ左下にある「表示オプション」領域で、対象にしたい拡張子にチェックを入れると、その拡張子のみが対象になります。 1つもチェックを入れないでおくと、すべてのファイルが対象になります。 望みの拡張子がリストにない場合は、「追加」ボタンで自由に追加できます。 チェックを入れたり外したりしたら、最後に必ず「上記の設定で再描画」ボタンをクリックして下さい。 すると、指定された拡張子に限定してリストが再構築されます。


初回起動時・新規プロジェクト作成時の設定 - Fumy RSS & Atom Maker マニュアル

Fumy RSS & Atom Maker Ver 0.85β
オンラインヘルプ 2007年05月05日版
概要 → 初回起動時・新規プロジェクト作成時の設定

初回起動時・新規プロジェクト作成時の設定

初回起動時や、新規作成時には、以下の設定が必要です。

新規作成の各項目：

  • 初回起動時 ： 各データファイル名の決定。
  • 新規プロジェクトの作成 ： 新しくウェブサイトの情報を登録。

初回起動時

初回起動時には、必ず「新規プロジェクト作成」ダイアログが表示されます。 本ソフトウェアを使用する前には、ここで必ず、各種データを保存するファイル名を決定する必要があります。

1 | Fumy RSS & Atom Maker アイコン | 本ソフトウェアを起動するには、左図のようなアイコンのファイル（fRssAtom.exe）をダブルクリックするなどして実行します。
2 | 初回起動時の画面 （画像クリックで拡大） | すると、左図のようなウインドウが開きます。 初回起動時は、何もしなくてもメインウインドウの上に「新規プロジェクト作成」ダイアログが表示されます。 「簡易セットアップ」を選択して、「次へ」ボタンをクリックします。 ※「簡易セットアップ」と「詳細セットアップ」が選択できますが、初回起動時は「簡易セットアップ」を選択しておけば十分です。
3 | 簡易セットアップの完了 （画像クリックで拡大） | 簡易セットアップでは、何も入力する必要はありません。 ただ、「完了」ボタンをクリックして下さい。 以上で、初回起動時の操作（デフォルトデータファイルの作成）は完了です。 ※具体的には、デフォルトのファイル名で、設定ファイルが4つ自動生成されます。（詳細セットアップを選択していれば、各ファイル名を自分で指定できます。）

これ以降の具体的な設定は、以下の「新規プロジェクト作成時」項目の 手順2 からをご参照下さい。

新規プロジェクトの作成

新たに別のウェブサイトに関するRSSを生成させたい場合は、新しくプロジェクトを作成します。 新たにプロジェクトを作成したい場合は、以下の手順で操作します。

1 「新規サイト」ボタン 新規プロジェクトを作成するには、ツールバー上にある「新規サイト」ボタンをクリックするか、メニューの「プロジェクト」→「新規サイト」をクリックします。
2 「新規作成」画面
（画像クリックで拡大） 		すると、左図のような新規プロジェクト作成ダイアログ（ウィザード）が開きます。
このウィザードを使って各種データを保存するファイル名を決定します。
  • 「簡易セットアップ」を選択すれば、自動的にファイル名が決定されますので、 扱うサイト数が少ない場合は、「簡易セットアップ」を選択するのが楽です。
  • 「詳細セットアップ」では、ファイル名を自分で決定できます。

(A) 簡単な方法（簡易セットアップを使う場合）：

3 | 「新規作成」画面 （画像クリックで拡大） | 「簡易セットアップ」を選択すれば、自動的にファイル名が決定されますので、 ユーザは何も入力する必要がありません。 「簡易セットアップ」をクリックしてから、「次へ」ボタンをクリックします。
4 | 簡易セットアップの完了 （画像クリックで拡大） | 最後に「完了」ボタンをクリックして下さい。 これで、新規プロジェクトの作成操作は完了です。

(B) 詳しく設定する場合（詳細セットアップを使う場合）：

3 | 「新規作成」画面 （画像クリックで拡大） | 「詳細セットアップ」では、生成するデータファイル名のすべてを自分で決定できます。 また、一部のデータファイルを、他のプロジェクトのデータファイルと共用することもできます。 「詳細セットアップ」をクリックしてから、「次へ」ボタンをクリックします。
4 | プロジェクトファイル名の入力 （画像クリックで拡大） | まずは、プロジェクトファイルのパス（保存先フォルダとファイル名）を指定します。 デフォルトで、「default5.frp」などのファイル名が入力されていますが、ウェブサイトを連想しやすい分かりやすいファイル名に変えると良いでしょう。 入力できたら「次へ」ボタンをクリックします。 ※ファイル拡張子は、.frp のままにして下さい。 ※存在しないフォルダは指定できませんので、新しいフォルダに保存したい場合は、先にフォルダを作成しておいて下さい。
5 | データファイル名の入力1 （画像クリックで拡大） 個別ファイルの設定 | 次に、詳しい設定を保存するためのデータファイル名を決定します。 ここは、プロジェクトファイル名から自動的に決定されています。 そのままだと、プロジェクトファイルと一緒に、各種データファイルもすべて新規作成されます。 しかし、例えば「出力設定ファイルは既存のファイルと同じ内容で構わない」という場合は、再度同じ設定を行うのは面倒です。 そこで、左図の赤枠の部分を使えば、特定のデータファイルのみ、既存のファイルをそのまま新プロジェクトに流用する設定を行うことができます。 右側の「別指定」ボタンをクリックすると、流用したいデータファイルを選択できるようになります。 そこで、既存のファイルを指定すれば、そのファイルが新プロジェクトでも使用されるようになります。 ※既存のファイルを流用する設定にして新規プロジェクトを作成した場合、既存のファイルのコピーが作られるわけではなく、既存のファイルがそのまま使用されます。ですから、既存のファイルを別のプロジェクトでも使用している場合、一方のプロジェクトで変更した設定は他方のプロジェクトにも反映されることになります。 設定できたら「次へ」ボタンをクリックします。
6 | データファイル名の入力2 （画像クリックで拡大） | 最後に、動作設定を保存するためのデータファイル名を決定します。 ここも、プロジェクトファイル名から自動的に決定されています。 動作設定は、「Fumy RSS & Atom Maker」の動作に関する設定ですから、 ウェブサイトごとに別々に用意する必要性はあまりありません。 そこで、ここは他のプロジェクトと共用にしておく方が便利です。 ※標準設定のままだと、新規作成されます。 設定できたら「次へ」ボタンをクリックします。
7 | 簡易セットアップの完了 （画像クリックで拡大） | 最後に「完了」ボタンをクリックして下さい。 これで、新規プロジェクトの作成操作は完了です。

「完了」ボタンをクリックしたときに、各設定ファイルが生成されます。（「完了」ボタンをクリックしない限り、生成されることはありません。）

「初回起動時・新規プロジェクト作成」に関する説明は以上です。


メインウインドウの説明 - Fumy RSS & Atom Maker マニュアル

Fumy RSS & Atom Maker Ver 0.76
オンラインヘルプ 2007年02月16日版
概要 → メインウインドウの説明

メインウインドウの説明

Fumy RSS & Atom Maker の画面イメージです。
標準のウインドウサイズは、ご使用のデスクトップの面積によって異なります。 例えば、1280×1024解像度のデスクトップの場合は、960×722で起動します。
※ウインドウサイズが小さすぎると、一部の項目が見えなくなる可能性があります。デスクトップの解像度が800×600以下の場合は、ウインドウを最大化して使用されることをお勧め致します。

① | タイトルバー | 現在読み込まれているプロジェクトファイル名が表示されています。
② | ツールバー | プロジェクトの作成・読み込み、RSS・Atomフィードの作成、各種設定などの機能を呼び出すことができます。
③ サイト情報 現在読み込まれているプロジェクトが対象としているウェブサイトの名称とURL、ローカルフォルダ名が表示されています。未設定の場合は、まずは「サイト設定」を行う必要があるという旨の表示が出ます。
URLをクリックすると、ブラウザが起動して対象URLにアクセスできます。 フォルダ名をクリックすると、マイコンピュータで対象フォルダを開きます。
④ 情報ボックス 上部には全体の情報が、下部にはファイルリスト（⑥）で選択されているファイルに関する情報が表示されています。
走査フォルダ数 | 対象となるフォルダ以下にあるサブフォルダの数です。
合計ファイル数 | 対象となるフォルダ以下にある全ファイル数です。
除外フォルダ数 | サイト設定で、RSSの対象外に設定されているフォルダの数です。
対象ファイル数 | 除外設定や拡張子制限などを考慮した結果、RSSの対象候補となるファイル数です。
選択ファイル情報欄：
ファイル名 | クリックするとローカルファイルを開きます。（HTMLならブラウザが起動します。その他、マイコンピュータでアイコンをダブルクリックしたときと同じ結果になります。）
対応URL | そのファイルがサーバにアップロードされた場合のURLです。クリックするとブラウザでそのURLを開きます。（正しく閲覧できない場合は、「サイト設定」のフォルダ設定が誤っています。）
ツールバー | それぞれ、対象ファイルに対して以下の操作を行います。 左から1番目：ファイルのあるフォルダを開きます。 左から2番目：ファイルを（シェルで）開きます。 左から3番目：ファイルをテキストエディタで開きます。 左から4番目：URLをブラウザで開きます。
⑤ リストツールバー ファイルリスト（⑥）の並べ替えや、特定ファイルの一時的な除外（RSSフィードに含める対象から除外）を指定できます。
「収録数」欄で入力した数だけ、RSS・Atomフィードに含められます。 どこまでのファイルがフィードに含まれるかは、⑦で分かります。
「ツリー再走査」ボタンをクリックすると、フォルダとファイルの読み込みをやり直します。
⑥ ファイルリスト 対象フォルダ内に含まれるすべてのファイルのリストが更新時刻順に表示されています。 （⑧で対象拡張子を制限している場合は、表示対象になっている一部のファイルだけが表示されます。）
ファイルをクリックすると、情報ボックス（④）にそのファイルに関する情報が表示されます。
また、右クリックすることで、様々な操作を行うコンテキストメニューが表示されます。 （表示されているファイルリストをCSV形式で保存することもできます。）
⑦ RSS対象 RSS・Atomフィードに含まれる対象になっているファイルは、この番号欄の背景色が水色になります。 灰色のファイルは、フィードには含まれません。
フィードに含まれる数を調整するには、⑤の「収録数」欄を使用します。
⑧ オプションボックス 対象とするファイル拡張子を指定します。
対象にしたいファイル拡張子にチェックを入れれば、その拡張子のみがファイルリスト（⑥）に表示されます。
すべてのチェックを外せば、すべての拡張子を対象にできます。
望みの拡張子がリストにない場合は、「追加」ボタンで自由に追加できます。
※チェックを入れたり外したりした後は、「上記の設定で再描画」ボタンをクリックして下さい。これをクリックしないと、ファイルリストは更新されません。


ウェブサイトに関する基本情報を設定する - Fumy RSS & Atom Maker マニュアル

Fumy RSS & Atom Maker Ver 0.94β
オンラインヘルプ 2008年01月08日版
概要 → ウェブサイトに関する基本情報を設定する

ウェブサイトに関する基本情報を設定する

本ソフトウェアを用いてRSSフィードやAtomフィードを生成するためには、対象とするウェブサイトに関する基本情報の設定が必須です。 ここで、HTMLが格納されているフォルダを指定したり、アップロード先のURLを指定したり、HTMLから情報を自動抽出するための方法を選択したりします。 これらの設定は、最初に行っておく必要があります。

また、必須ではありませんが、本ソフトウェアを用いてRSSフィードやAtomフィードのアップロードまで行いたい場合は、 FTP接続に関する設定も、ここで設定しておきます。

サイト設定の各項目：

  • サイト情報 ： タイトルやURL・概要などを登録。【必須】
  • 作者情報 ： 作者の名前やURLなどを登録。【一部必須】
  • ファイル・フォルダ設定 ： HTMLのあるフォルダ、アップロード先、文字コードの指定など。【必須】
  • 情報抽出方法 ： RSS/Atomフィードに含める情報の自動抽出方法を選択。【必須】
  • 固定追加ページ ： 更新日時に関係なく常にRSS/Atomフィードに含めたいファイルを指定。《オプション》
  • 除外規則 ： 自動抽出の対象にしたくないファイルの条件を指定。《オプション》
  • FTP ： 内蔵FTP機能の設定。《オプション》
  • Ping ： Update Ping送信機能の設定。《オプション》

「サイト設定」ウインドウの表示

「サイト設定」ウインドウは、メインメニューが表示されている状態で、ツールバーを操作することで表示できます。

1 | 「サイト設定」ボタン | ツールバー上にある「サイト設定」ボタンをクリックするか、メニューの「設定」→「サイト設定」をクリックします。
2 | 「サイト設定」画面 （画像クリックで拡大） | すると、左図のようなウインドウが開きます。（最初には「サイト情報」タブが選択されています。） このウインドウで、RSS/Atomフィードを生成する対象のウェブサイトに関する、基本的な設定を行います。

各設定項目について、以下で詳しく説明しています。 必須項目は、必ず何か入力するようにして下さい。 必要な情報が不足していると、正しくRSS/Atomフィードが生成できない可能性があります。

サイト情報の登録 【必須項目あり】

「サイト情報」ページ内には、「基本情報」と「拡張情報」の2つのサブページがあります。 「基本情報」ページでは、ウェブサイトの名称やURL、更新頻度などの情報を指定し、 「拡張情報」ページでは、ロゴ画像の位置や補足情報を登録できます。

1 「サイト設定」－「基本情報」
（画像クリックで拡大） 		左図の「基本情報」ページでは、次の項目を登録します。

サイト基本情報：【必須】
  • タイトル： ウェブサイト名
  • URL： ウェブサイトのURL
  • 概要： ウェブサイトの紹介文
  • 言語： ウェブサイトの言語（日本語の場合は ja を選択）
  • 著作権： 著作権情報
サイト更新頻度情報：
  • 更新間隔： 毎日・毎週・毎月など
  • 更新頻度： 上記期間中に何回くらい更新するか
2 「サイト設定」－「拡張情報」
（画像クリックで拡大） 		左図の「拡張情報」ページでは、次の項目を登録します。（必須項目なし）

ロゴ情報：
  • ウェブサイトのロゴ画像が用意されている場合は、ここにURLや代替文字を入力します。「リンク先URL」は、そのロゴがクリックされたときにどこへ移動させたいかを指定しておきます。
補足情報：
  • ジャンル・提供母体名・協力者名を指定できます。

以上で、サイト情報の登録は完了です。「サイト基本情報」のみ登録必須です。それ以外の項目は空欄でも構いません。

作者情報の登録 【必須項目あり】

ウェブサイトの製作者に関する情報を登録します。

1 「作者情報」
（画像クリックで拡大） 		左図の「作者情報」ページでは、次の項目を登録します。
  • 名前： ウェブサイトの作者名
  • メール： 作者のメールアドレス
  • URL： 作者を示すURL
入力が必須なのは、名前だけです。
特にメールアドレスを公開したくない場合は、メールアドレス欄は空欄のままにしておいて下さい。

ここでの必須項目は、「名前」のみです。

ファイル・フォルダ設定 【必須項目あり】

ウェブサイトのHTMLなどのファイルが格納されているフォルダの指定や、ウェブ上での公開先URLの登録を行います。 自動的に更新されたファイルを抽出するためや、正しくリンクするRSS/Atomフィードを生成するためにも、これらの設定は非常に重要です。

1 「ファイル・フォルダ設定」
（画像クリックで拡大）
「ローカルフォルダ」項目【必須】：
対象ウェブサイトのHTMLファイルなどが格納されているフォルダを指定します。
ここで指定した以下のすべてのフォルダに含まれるファイルが、RSS/Atomフィードに含める対象になります。
「サーバURL」項目【必須】：
対象ウェブサイトのURLを指定します。
※「ローカルフォルダ」と（階層的に）対応の取れたURLを入力しないと、正しくリンクするRSS/Atomフィードが生成されませんので注意して下さい。
「出力先」項目【必須】：
RSSフィード・Atomフィードの出力先パス名（フォルダ名＋ファイル名）を指定します。 この位置に、各フィードが出力されます。
この項目は必須項目ですが、「ローカルフォルダ」欄を入力すると、自動的に決定されます。（自動的に決定された位置に問題がある場合は、手動で変更して下さい。）
「文字コード」項目：
サーバの文字コードに合わせてRSS/Atomフィードを生成します。 ここで何を指定していても、実際に出力する段階で文字コードを選び直すこともできます。

ここの設定を誤ると、生成されたRSS/Atomフィードが、正しく各エントリ（ページ）を指し示せない可能性があります。 初回に設定したときは、RSS/Atomフィードからウェブサイトに正しくリンクが張られているか確認して下さい。 もし、正しくリンクが作られていないようなら、ここの設定を見直して下さい。

情報抽出方法の登録 【必須項目あり】

HTMLファイルから、どうやって自動的にRSS/Atomフィードに含める情報を抽出するかを、ここで決定します。 ここでの設定次第で、うまく情報を抽出できたりできなかったりしますので、主なHTMLファイルの記述スタイルに合わせた設定を行って下さい。 【全項目必須】

1 「情報抽出方法」
（画像クリックで拡大） 		HTMLファイルからの情報抽出では、次の4つの情報を自動的に抽出します。
  • タイトル（ページのタイトル）
  • 概要（サマリー）
  • 内容（本文）
  • カテゴリ（ジャンル）
これらの4つについて、なにを基準に抽出するかを設定します。

4つとも、「指定要素」から抽出するか、「指定文字列」に挟まれた範囲を抽出するかを選ぶことができますが、 概要とカテゴリに関しては、「meta要素のcontent属性」から抽出するオプションもあります。（デフォルトではそれが選択されています。）

主に普段記述されているHTMLのスタイルに合わせて、設定を変更して下さい。

※該当箇所が複数存在する場合にどこから取得するかの設定は、現行バージョンでは「先頭」しか選択できません。

デフォルトの設定のままでも、最低でも「ページタイトル」は抽出できるはずです。 もし、何も抽出されていないようなら、このページの設定を見直して下さい。
なお、「概要（サマリー）」と「内容（本文）」に関しては、設定された情報抽出方法で何も取得できなかった場合に限り、自動的に他の方法で情報抽出を試みます。

固定追加ページの登録

ファイルの更新時刻に関係なく、常にRSS/Atomフィードに収録したいファイルがあれば、登録しておくことができます。 （そのようなファイルがない場合は、ここで設定する項目は何もありません。）

1 「固定追加ページ」
（画像クリックで拡大） 		「固定追加ページ」の登録を追加するには、「対象HTML追加」ボタンをクリックします。 そして、対象となるHTMLファイルと、そのファイルが対応するウェブ上のURLを入力します。

既に登録されている「固定追加ページ」の情報を書き換えたい場合は、書き換えたい項目を（クリックして）選択した上で「編集」ボタンをクリックします。
既に登録されている「固定追加ページ」を削除したい場合は、削除したい項目を（クリックして）選択した上で「削除」ボタンをクリックします。

対応URL欄には、ベースとなるURLを含まないようご注意下さい。ベースとなるURLを含まずに、「 / 」から始まる絶対パスで場所を指定します。 例えば、「 http://www.nishishi.com/hogehoge/index.html 」を指定したい場合は、ベースURLを除いて「 /hogehoge/index.html 」とだけ記述します。

除外規則の登録

「特定の条件に一致するファイルは、たとえ最近更新されていてもRSS/Atomフィードには含めないでおきたい。」という場合には、 このページで除外規則を登録しておくことで、フィードに含まないようにできます。

1 「除外規則」
（画像クリックで拡大） 		◆特定のフォルダを除外したい場合：
除外したいフォルダを登録するには、「除外フォルダを追加」ボタンをクリックします。 すると、フォルダの一覧が表示されるので、除外したいフォルダすべてにチェックを入れます。

◆特定のファイルや、部分一致する文字列、正規表現で除外対象を指定したい場合：
「除外ルールを追加」ボタンをクリックします。 すると、文字列の入力画面が表示されるので、「除外したいファイル名」もしくは「除外したいファイルのパス名の全部または一部」もしくは「除外したいファイルに一致する正規表現」を入力します。

既に登録されている「除外規則」を削除したい場合は、削除したい項目を（クリックして）選択した上で「削除」ボタンをクリックします。
2 除外ルールの作成
「除外ルールを追加」ボタンをクリックすると、このようなダイアログが表示されます。ここに、
  • 除外したいファイルのパス名の全部または一部
  • 除外したいファイル名（完全一致）
  • （除外したいファイルに一致する）正規表現
…のいずれかを入力して下さい。さらに、下部の適用方法（1～3）の中から適切なものを選んで下さい。
正規表現を入力した場合は、その正規表現でどのようなファイルを除外可能か、確認することができます。 確認するには、「正規表現のチェック」ボタンをクリックして下さい。
3 除外ルールの作成
正規表現の確認ダイアログでは、確認文字列欄に、適当なファイルパス（ D:\Web\index.html など）を入力して、 指定の正規表現で一致できるかどうかを確認することができます。
「サンプルを入力」という箇所をクリックすると、正規表現と確認文字列のサンプルが入りますので、参考にして下さい。

ファイル拡張子で制限したい場合は、このウインドウではなく、メインウインドウ左下にある「表示オプション」欄を使います。

FTP情報の登録

内蔵のFTP機能を使って、RSS/Atomフィードをサーバにアップロードしたい場合は、ここでFTPサーバへの接続設定を入力しておくと便利です。 （ここで入力せず、アップロード時に毎回必要な情報を入力することもできます。）

1 「FTP情報」
（画像クリックで拡大） 		FTP接続に関しては、次の4項目が必要です。
  • 接続先ホスト名： アップロード先のサーバの名前またはIPアドレスを入力します。
  • アカウント名： サーバにログインするためのIDを入力します。
  • パスワード： 上記のIDでログインするためのパスワードを入力します。
  • アップロード先ディレクトリ： サーバ上でRSS/Atomファイルをアップロードする先のディレクトリをフルパスで指定します。
パスワードを保存させたくない場合は、パスワード欄を空欄のままにしておいて下さい。 FTP接続時にパスワードをその都度指定することができます。

必要に応じてオプションを設定して下さい。
サーバによっては、PASV（パッシブ）モードでないと通信できない場合があります。 その場合は、「PASV（Passive）モードを使う」にチェックを入れます。

FTPサーバとなかなか通信できない場合は、タイムアウト時間を長めに設定してみて下さい。

※アップロード先ディレクトリに設定すべき内容が分からない場合は、とりあえず空欄にしたまま実行してみて下さい。それでうまくアップロードできるようなら、空欄のままで構いません。

パスワードをこの画面から入力した場合は、暗号化して保存されます。ただし、暗号強度は強くありませんので、自分以外の人が使用する可能性のあるパソコンでは（パスワードだけは）保存しないことをお勧め致します。 （パスワードを保存しなければ、毎回のFTP時にパスワードの入力を求められますから、そこで入力して下さい。）

Update Ping情報の登録

内蔵のUpdate Ping 送信機能を使って、各Pingサーバに対してRSS/Atomフィードが更新された情報を伝えることができます。 ここで、Pingサーバの登録や、どのPingサーバを利用するかの設定をしておくと便利です。

1 「Ping」
（画像クリックで拡大） 		ここでは、Pingサーバの登録と、そのPingサーバを利用するかどうかの設定を行えます。
Pingサーバの登録情報は、すべてのプロジェクトで共通です。 どのPingサーバを使うかの設定は、各プロジェクトごとに個別に保持されます。

Pingサーバを追加するには、「Pingサーバを追加」ボタンをクリックして、URLを入力します。 実際にUpdate Ping を送信するPingサーバを選ぶには、PingサーバのURLの頭にチェックを入れます。

Pingサーバとの通信がうまくいかない場合は、オプション項目にあるタイムアウト時間を長めに設定してみて下さい。 なお、Pingサーバがタイムアウトしても、Pingそのものは正常に送信できている場合が多くあります。 タイムアウトする割合がそう多くない場合は、あまり気にする必要はありません。

Pingサーバからのレスポンスを、サーバごとに別個のXMLファイルに自動保存させることもできます。 自動保存させるには、「Pingサーバのレスポンスを個別にファイル化」というチェックボックスにチェックを入れて下さい。
XMLファイルは、アプリケーションを格納しているフォルダに PingRes1.xml 、 PingRes2.xml 、PingRes3.xml …… のようなファイル名で保存されます。（※番号は、Pingサーバの設定番号です。現行バージョンでは、ファイル名の指定はできません。）

（デフォルトでは11個のPingサーバが登録されていて、そのうち先頭4つのサーバを使用するよう設定されています。）

「サイト設定」に関する説明は以上です。


RSS/Atomフィードに関する詳細設定 - Fumy RSS & Atom Maker マニュアル

Fumy RSS & Atom Maker Ver 0.71β
オンラインヘルプ 2006年03月13日版
概要 → RSS/Atomフィードに関する詳細設定

RSS/Atomフィードに関する詳細設定

本ソフトウェアを用いて出力するRSSフィードやAtomフィードの内容や構成に関する詳細な設定を行うことができます。 この設定はオプションであり、何も設定を変更せず、標準設定のまま使用しても問題はありません。 望みのRSS・Atomフィードの構成がある場合は、ここから細かな設定を行って下さい。

（このページでの設定には、必須項目はありません。）

出力設定の各項目：

  • RSS/Atomフィード全般 ： 最大文字数の指定、使用モジュールの選択。
  • RSS/Atomヘッダ編集 ： XSLの指定、ヘッダの自由編集。
  • （モジュール）Dublin Core ： 作者情報・ジャンル・著作権表示などの選択。
  • （モジュール）Syndication ： 更新期間・更新頻度情報に関して。
  • （モジュール）Content ： RSSフィードにコンテンツ全体を含める指定。
  • Podcast ： Podcast（ポッドキャスト）用RSSを出力する設定。
  • URL ： RSSに含めるURLの表記方法に関する設定

「出力設定」ウインドウの表示

「出力設定」ウインドウは、メインメニューが表示されている状態で、ツールバーを操作することで表示できます。

1 | 「出力設定」ボタン | ツールバー上にある「出力設定」ボタンをクリックするか、メニューの「設定」→「出力設定」をクリックします。
2 | 「出力設定」画面 （画像クリックで拡大） | すると、左図のようなウインドウが開きます。（最初には「RSS1.0」タブが選択されています。） このウインドウで、出力するRSS/Atomフィードに関する詳細な設定を行います。 ※ここで、設定が必須な項目は1つもありません。すべて、デフォルト設定のまま使用しても、正しくRSS・Atomフィードは生成されます。生成されたフィードが気に入らない場合や、出力をカスタマイズしたい場合に利用して下さい。

各設定項目について、以下で詳しく説明しています。 必須項目はありませんが、既に入力されている内容を削除するなど、 必要な情報が不足すると、正しくRSS/Atomフィードが生成できない可能性がありますのでご注意下さい。

RSS/Atomフィード全般の設定

「RSS1.0」・「RSS2.0」・「Atom0.3」ページ内には、「全般」と「ヘッダ」の2つのサブページがあります。 ここでは、「全般」側の説明をします。

1 「出力設定」画面
（画像クリックで拡大） 		左図の「全般」ページでは、次の項目を登録します。※ここでは例として「RSS1.0全般」ページ。

基本設定：
  • タイトルの最大文字数
  • 概要の最大文字数
モジュールの設定：
  • モジュール Dublin Core を使うかどうか
  • モジュール Syndication を使うかどうか
  • モジュール Content を使うかどうか
※指定した最大文字数を超えると「 ... 」を表示して以降を省略するようになります。
※RSS1.0では、「Dublin Core」を使わない設定にすると、更新情報を伝えるRSSとしては情報不足なフィードになってしまいますのでご注意下さい。

ここでの「最大文字数」は、「最大バイト数」と同義です。日本語文字は、1文字で2バイトですから、最大文字数の指定が128文字のとき、すべてが日本語文字だとすると、実際に使用される文字数は64文字になります。

RSS/Atomヘッダ編集

「RSS1.0」・「RSS2.0」・「Atom0.3」ページ内には、「全般」と「ヘッダ」の2つのサブページがあります。 ここでは、「ヘッダ」側の説明をします。

1 「出力設定」画面
（画像クリックで拡大） 		左図の「ヘッダ」ページでは、次の項目を登録します。※ここでは例として「RSS1.0全般」ページ。
  • XMLヘッダを付加するかどうか
  • XSLを指定するかどうか
  • RSS/Atomヘッダの確認（編集も可）
※RSS/Atomヘッダは、「全般」側で選択したモジュールに合わせて、適切なヘッダが生成されるようになっています。手動で編集する場合は、モジュールに合わせて必要な情報をすべて記述するよう気を付けて下さい。

※ここでの設定は、RSS1.0・RSS2.0・Atom0.3で、それぞれ別々に保存されます。

（モジュール）Dublin Core に関する設定

モジュール「Dublin Core」では、作者情報・ジャンル・著作権表示などの情報を含めるかどうかを指定できます。 ここでの設定は、RSS1.0・RSS2.0・Atom0.3すべてに共通して有効になります。

1 「出力設定」画面 Dublin Core ページ
（画像クリックで拡大） 		左図の「Dublin Core」ページでは、RSS/Atomフィード内に次の項目を含めるかどうかを選択します。
  • ファイル更新日を含めるかどうか
  • 作者名を含めるかどうか
  • ジャンル・分類名を含めるかどうか
  • メディアタイプを含めるかどうか
  • サイト提供母体名を含めるかどうか
  • サイトの協力者名を含めるかどうか
  • 内容の種類を含めるかどうか
  • 識別IDを含めるかどうか
  • 言語名を含めるかどうか
  • 著作権表示を含めるかどうか
含めたい項目にだけチェックを入れます。
※「ファイル更新日」のチェックを外すと、RSS1.0では更新日時情報を含めなくなってしまいますので、外さないようにして下さい。

ここで何を指定していても、RSS1.0・RSS2.0・Atom0.3の各設定で「Dublin Coreを使う」設定になっていなければ、これらの情報はフィードに含まれません。

（モジュール）Syndication に関する設定

モジュール「Syndication」では、更新頻度に関する情報を含めるかどうかを指定できます。 ここでの設定は、RSS1.0・RSS2.0・Atom0.3すべてに共通して有効になります。

1 「出力設定」画面 Syndication ページ
（画像クリックで拡大） 		左図の「Syndication」ページでは、RSS/Atomフィード内に次の項目を含めるかどうかを選択します。
  • 更新期間：
    • daily（毎日）, weekly（毎週）, monthly（毎月）, yearly（毎年）...
  • 更新頻度：
    • 数値で指定
例えば、更新期間が「weekly（毎週）」で、更新頻度が「3」なら、「毎週3回更新」という意味になります。

ここで何を指定していても、RSS1.0・RSS2.0・Atom0.3の各設定で「Syndicationを使う」設定になっていなければ、これらの情報はフィードに含まれません。

（モジュール）Content に関する設定

モジュール「Content」では、フィードにコンテンツ全体を含める場合の含め方を指定します。 ここでの設定は、RSS1.0・RSS2.0・Atom0.3すべてに共通して有効になります。

※RSSでは、「Contentモジュール」を使用する設定にしないとここでの設定は使用されません。 Atomでは、「Content要素」を使用する設定にしていないとここでの設定は使用されません。

1 「出力設定」画面 Content ページ
（画像クリックで拡大） 		左図の「Content」ページでは、次の項目を設定します。
  • 最大文字数
  • 内容設定：
    • 内容に含まれるHTML・XHTMLもすべて含める
    • 内容に含まれる文字列だけを抜き出す（HTML・XHTMLタグを取り除く）
最大文字数に「 0 」を指定すると、文字数無制限になります。（どんなに長い文字列でもすべてを取り込みますので、ご注意下さい。）

ここで何を指定していても、RSS1.0・RSS2.0・Atom0.3の各設定で「Contentを使う」設定になっていなければ、これらの情報はフィードに含まれません。

Podcast（ポッドキャスト）用RSSを出力する設定

Podcast用のRSSを作成するための設定については、「Podcast（ポッドキャスト）用RSSを出力するには」ページで詳しく説明しています。

RSSに含めるURLの表記方法に関する設定

index.htmlなど、ファイル名を省略してもアクセス可能なファイルに対して、ファイル名を省略したURLで記載するか、それともファイル名まで含めたURLで記載するかを設定できます。
標準では、ファイル名まで含めたURL表記が採用されます。

1 「出力設定」画面 URL ページ
（画像クリックで拡大） 		左図の「URL」ページでは、デフォルトファイル名を省略したURL表記を採用するかどうかの設定と、デフォルトファイル名として解釈するファイル名の設定を行います。

デフォルトファイル名には、標準で「 index.html 」、「 index.shtml 」、「 index.htm 」の3つのファイルが登録されています。 これら以外にもデフォルトファイル名がある場合は、ここで登録して下さい。

※標準ではOFFです。省略したURL表記を使用したい場合は、ここでチェックを入れておく必要があります。
※デフォルトファイル名は、プロジェクトごとに保持されます。

「出力設定」に関する説明は以上です。


動作設定 - Fumy RSS & Atom Maker マニュアル

Fumy RSS & Atom Maker Ver 0.75β
オンラインヘルプ 2007年01月26日版
概要 → 動作設定（表示に関する設定）

動作設定（表示に関する設定）

本ソフトウェアの表示に関して設定できます。

（このページでの設定には、必須項目はありません。）

「動作設定」ウインドウの表示

「動作設定」ウインドウは、メインメニューが表示されている状態で、ツールバーを操作することで表示できます。

1 | 「動作設定」ボタン | ツールバー上にある「動作設定」ボタンをクリックするか、メニューの「設定」→「動作設定」をクリックします。
2 | 「動作設定」画面 ウインドウ表示ページ （画像クリックで拡大） | すると、左図のようなウインドウが開きます。 最初に「ウインドウ表示」ページが開かれています。 ここでは、本ソフトウェア起動直後のウインドウ表示位置の設定ができます。 マルチディスプレイなどで、ウインドウの表示座標がマイナスになる可能性がある場合は、「マイナスの座標を許容する」にチェックを入れておいて下さい。 ここにチェックが入っていない場合、強制的にプラスの座標に移動されます。
3 | 「動作設定」画面 ヒント表示ページ （画像クリックで拡大） | 「ヒント表示」ページでは、ボタンや入力フォームなどの上にマウスを乗せた際に表示されるヘルプ（ツールチップ）に関する設定が行えます。 ツールチップは、表示しない選択も可能ですが、慣れるまでは「表示する」設定のままご使用になられることをお勧め致します。
4 | 「動作設定」画面 連携ソフト （画像クリックで拡大） | 「連携ソフト」ページでは、使用するテキストエディタの設定が行えます。 標準では「メモ帳」が使用されますが、任意のテキストエディタを指定することもできます。

この「動作設定」も、プロジェクトごとに保持されます。
このソフトウェアの望ましいウインドウサイズの最低値は、800×580です。できるだけ、これよりも大きいウインドウサイズでご使用になられることをお勧め致します。

「動作設定」に関する説明は以上です。


FTP機能を使う - Fumy RSS & Atom Maker マニュアル

Fumy RSS & Atom Maker Ver 0.76β
オンラインヘルプ 2007年02月16日版
概要 → FTP機能を使う

FTP機能を使う

内蔵のFTP機能を使えば、作成したRSSフィードやAtomフィードを、手軽にサーバにアップロードすることができます。 別途FTPソフトを用意する必要はありません。

内蔵のFTP機能を用いてサーバに接続するためには、事前にサーバに接続するための設定を行っておく必要があります。 FTPサーバに接続するための設定は、「サイト設定」の「FTP設定」項目から行って下さい。

このページでは、FTPサーバに接続するための設定が完了していることを前提に、FTPサーバへ接続してRSSフィードやAtomフィードをアップロードする方法を説明しています。

FTP機能の起動

FTP機能は、メインメニューが表示されている状態で起動することができます。

1 | 「FTP」ボタン | 内蔵のFTP機能を使用するには、メインウインドウのツールバーにある「FTP/Ping」ボタン（左図）をクリックして、「FTPでアップロード」メニューをクリックするか、 メニューの「走査・出力」→「FTPでアップロード」をクリックします。
2 | FTPウインドウ （画像クリックで拡大） | すると、左図のようなウインドウが開きます。 ここで、FTP接続を行います。 FTPの設定が正しく行われていれば、すべての項目には適切な値が最初から入力された状態になっていますので、 「接続」ボタンをクリックしさえすれば、アップロードできます。（詳しくは下記参照）

すべての設定が整っている状態であれば、このウインドウで行うことは「接続」ボタンをクリックすること、ただ1つだけです。 他には何もする必要はありません。 「接続」ボタンのクリックだけで、サーバへの接続・ファイルのアップロード・サーバからの切断...という一連の処理が完了します。 （従って、特に問題がなければ、以下の説明を読む必要はないでしょう。）

FTPウインドウ

FTPウインドウは、次の項目で構成されています。

FTPウインドウ(説明用番号付き)
（画像クリックで拡大）

① 接続先ホスト名： アップロード先のサーバの名前またはIPアドレスを入力します。
② 接続ユーザID： サーバにログインするためのIDを入力します。
③ 接続パスワード： 上記のIDでログインするためのパスワードを入力します。
④ アップロード先： サーバ上でRSS/Atomファイルをアップロードする先のディレクトリをフルパスで指定します。
⑤ アップロード対象ファイル： 今回アップロードしたいRSS/Atomフィードを選択します。
⑥ FTP接続状況ログ： サーバとの通信状況が表示されます。エラーメッセージもここに表示されます。
⑦ 接続ボタン： アップロードを開始します。
⑧ 閉じるボタン： このFTPウインドウを閉じます。ウインドウの[×]ボタンをクリックしても同じです。

「サイト設定」で、FTPの設定が完了していれば、どの項目にも入力済みの状態でウインドウが開きます。
もし空欄があれば、ここで入力します。（例えば、パスワードを保存しなかった場合は、パスワード欄は空欄になっていますので、このウインドウで入力します。）

FTP接続・アップロード

内蔵のFTP機能を用いてサーバに接続し、RSSフィードやAtomフィードをアップロードするにか、以下のように操作します。

1 | FTPウインドウ(接続ボタン) （画像クリックで拡大） | 「接続先ホスト」欄・「接続ユーザID」欄・「接続パスワード」欄・「アップロード先」欄に適切に入力されていることを確認し、 ウインドウ右上の「接続」ボタンをクリックします。 ※「サイト設定」でパスワードを保存しなかった場合は、「接続パスワード」欄は空欄のままになっていますので、ここで入力して下さい。 ここで入力したパスワードは保存されないので安心です。（ウインドウを閉じると破棄されます。） ※IDやパスワードが空欄のまま「接続」ボタンをくりっくすると、サーバ接続時にエラーが出て、接続は完了しません。
2 | FTP接続中 （画像クリックで拡大） | 「接続」ボタンをくりっくすると、サーバへの接続処理が開始されます。 進行状況は、下部の「FTP接続状況ログ」に表示されます。 ここでは、作業が終わるのを待つだけで、特に何もする必要はありません。 ※Norton Internet Security などのセキュリティソフトを導入している場合、通信開始時にFTPの通信を許可するかどうかの質問ダイアログが出ることがあります。その場合は、「許可」するよう設定して下さい。
3 | FTP接続状況ログ | 特に問題が発生しなければ、［サーバへの接続］→［RSS/Atomファイルのアップロード］→［サーバからの切断］までの一連の処理が自動的に行われます。 その際、「FTP接続状況ログ」に表示される内容は、だいたい左図のようになります。 （アクセス先や設定によっては多少異なる可能性があります。） ※白色文字： 行おうとしている処理の内容 ※緑色文字： サーバからの反応（要求の成否） ※黄色文字： 行った処理の内容 ※赤色文字： 発生したエラーの内容 最後に、「処理を終了しました.」と表示されたら、アップロード完了です。

アップロードが完了したら、ウインドウを閉じて下さい。
もし、エラーメッセージが表示されたようなら、設定を見直してみて下さい。

なお、通信内容は、ログ表示欄を右クリックすることで、任意のテキストファイルに保存できます。

FTP接続のオプション設定

FTP接続がうまくいかない場合など、以下のオプションを設定することもできます。

1 FTP接続オプション
（画像クリックで拡大） 		パッシブモードでFTPサーバに接続しなければならない場合は、「高度な設定」ボタンをクリックすると表示される「接続モード」欄にある 「PASV（Passive）モード」というチェックボックスにチェックを入れて下さい。 すると、サーバにはパッシブモードで接続するようになります。

FTPサーバとの通信がうまくいかない場合は、タイムアウト時間を長めに設定してみて下さい。 10000ミリ秒（＝10秒）以上の任意の値を設定できます。

※ここでのオプション設定は、すべて一時的な設定変更になります。ずっと設定を変更しておきたい場合は、「サイト設定」ウインドウの「FTP」項目から設定して下さい。

FTP接続に関する説明は以上です。


Update Ping送信機能を使う - Fumy RSS & Atom Maker マニュアル

Fumy RSS & Atom Maker Ver 0.94β
オンラインヘルプ 2008年01月08日版
概要 → Update Ping送信機能を使う

Update Ping送信機能を使う

内蔵のUpdate Ping 送信機能を使えば、各Pingサーバに対してRSSフィードやAtomフィードを更新したという情報を伝えることができます。

Update Ping 送信機能を用いてPingサーバにUpdate Ping を送信するには、事前にPingサーバを登録しておく必要があります。（デフォルトで11個のPingサーバが既に登録されていますので、それ以外に登録したいサーバがなければ設定しなくても構いません。）
Pingサーバの設定は、「サイト設定」の「Ping」項目から行って下さい。

Update Ping送信機能の起動

Update Ping送信機能は、メインメニューが表示されている状態で起動することができます。

1 | 「Ping」起動メニュー | Update Ping送信機能を使用するには、メインウインドウのツールバーにある「FTP/Ping」ボタン（左図）をクリックして、「Update Ping を送信」メニューをクリックするか、 メニューの「走査・出力」→「Update Ping を送信」をクリックします。
2 | Pingウインドウ （画像クリックで拡大） | すると、左図のようなウインドウが開きます。 ここで、Update Pingの送信を行います。 ウインドウ上部には、登録済みのPingサーバの一覧が表示されていますので、Update Ping を送信したいPingサーバにチェックを入れます。 「送信」ボタンをクリックすれば、Update Ping の送信が開始されます。（詳しくは下記参照）

Pingサーバが登録されていて、送信したいPingサーバが選択されている状態であれば、このウインドウで行うことは「送信」ボタンをクリックすること、ただ1つだけです。 他には何もする必要はありません。 「送信」ボタンのクリックだけで、サーバへの接続・Update Ping の送信・サーバからの切断...という一連の処理が完了します。 （従って、特に問題がなければ、以下の説明を読む必要はないでしょう。）

Update Pingウインドウ

Update Pingウインドウは、次の項目で構成されています。

Update Pingウインドウ(説明用番号付き)
（画像クリックで拡大）

① Pingサーバリスト： Update Ping を送りたいサーバのリストです。
② 送信対象チェック： 実際にUpdate Ping を送信したいサーバにチェックを入れます。
③ Ping送信状況ログ： サーバとの通信状況が表示されます。エラーメッセージもここに表示されます。
④ 送信ボタン： このボタンをクリックして送信処理を開始します。
⑤ 閉じるボタン： ウインドウを閉じます。

Update Ping 送信

Update Ping 送信機能を用いてサーバに接続し、Pingを送信している間、通信ログは以下のような感じになります。

* Update Ping接続状況ログ 特に問題が発生しなければ、［サーバへの接続］→［Update Pingの送信］→［サーバからの切断］ → ［次のサーバへの接続］…という一連の処理が自動的に行われます。

最後に、「すべての送信処理は完了しました.」と表示されたら、Update Ping送信完了です。

サーバとの通信でエラーが発生した場合は、ログ内に赤色でエラー内容が表示されます。
サーバが混雑している場合など、サーバからの返事が届かなかった場合でもエラーが表示されます。 その場合は、何度も送信せず、時間をおいてから再度試してみて下さい。

なお、通信内容は、ログ表示欄を右クリックすることで、任意のテキストファイルに保存できます。

RSS Auto-Discovery の設定（記述）について

Update Ping を送信する前に、対象ウェブサイトのトップページのHTML内に、RSS Auto-Discovery の記述があるかどうかを確認して下さい。

「RSS Auto-Discovery」は、「そのウェブサイトに対応するRSS（Atom）フィードの場所」を、HTMLファイル内に記述しておく仕組みです。 この記述があれば、HTMLを参照するだけでRSS（やAtom）フィードの存在を知ることができます。 逆に、この記述がないと、RSSフィードの存在を知ることができません。

対象ウェブサイトのトップページのHTML内に、RSS Auto-Discovery の記述がない場合は、記述しておくようにして下さい。
RSS Auto-Discoveryの記述は、次のようにします。

<link rel="alternate" type="application/rss+xml" title="RSS 1.0" href="http://（RSS1.0のURL）" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://（RSS2.0のURL）" />
<link rel="alternate" type="application/atom+xml" title="Atom" href="http://（AtomフィードのURL）" />

…などのように、HTMLファイルのhead要素（<head>～</head>）に含めておきましょう。

もし、RSS Auto-Discoveryの記述が、対象ウェブサイトのトップページになく、別のページにのみ記述されている場合は、 次の設定を行って下さい。

1 Update Ping オプション
（画像クリックで拡大） 		「Ping設定補助」ボタンをクリックすると表示される「Pingに含める情報」欄にある 「送信するURL」という欄に、RSS Auto-Discoveryの記述のあるページのURLを入力します。

（標準では、トップページのURLが使われます。）

こうすることで、PingサーバがRSS/Atomフィードを読むことができるようになります。

その他のオプション設定について

Ping送信に関して、以下のオプションを設定できます。

1 Update Ping オプション2
（画像クリックで拡大） 		「Ping送信設定」ボタンをクリックすると、各種オプションの確認・設定ができます。

■タイムアウト時間の設定
「Timeout」という欄に、Pingサーバとの通信を行う際に反応を待機する最大時間の設定ができます。
単位はミリ秒です。10000ミリ秒以上の自由な値を設定できます。
ここでは、設定を一時的に変更できるだけです。ずっと設定を変更したい場合は、「サイト設定」ウインドウの「Ping」項目から設定して下さい。

■サーバレスポンスの保存
「Pingサーバのレスポンスを個別にファイル化」というチェックボックスにチェックを入れると、Pingサーバからのレスポンスを、サーバごとにXMLファイルとして保存することができます。
XMLファイルは、アプリケーションを格納しているフォルダに PingRes1.xml 、 PingRes2.xml 、PingRes3.xml …… のようなファイル名で保存されます。（※番号は、Pingサーバの設定番号です。現行バージョンでは、ファイル名の指定はできません。）

こうすることで、PingサーバがRSS/Atomフィードを読むことができるようになります。

Update Ping 送信機能に関する説明は以上です。


Podcast（ポッドキャスト）用RSSを出力するには - Fumy RSS & Atom Maker マニュアル

Fumy RSS & Atom Maker Ver 0.51β
オンラインヘルプ 2005年12月10日版
概要 → Podcast（ポッドキャスト）用RSSを出力するには

Podcast（ポッドキャスト）用RSSを出力するには

※この機能は試験的にサポートしています。現在のところ、iTunesで認識される必要最低限の要素しか出力していません。認識されないなどの問題があれば、サポートフォーラムなどでお知らせ下さい。

RSSフィードの収録対象として、MP3・M4Vなどの音楽ファイルや映像ファイルが指定されていれば、iTunes（iPod）に対して配信するためのPodcast（ポッドキャスト）用の要素が加わったRSSフィードを出力することができます。（※RSS 2.0 のみ）

Podcast用RSSフィードを作成するための出力設定

Podcast用RSSフィードが作成されるようにするには、「出力設定」ウインドウの「Podcast」ページで設定します。

出力設定ウインドウ「Podcast」ページ
（画像クリックで拡大）

① Podcastタブ： ここをクリックします。
② Podcast用出力を有効にするチェックボックス： 有効にする場合はチェックを入れます。
③ Podcast対象ファイル拡張子リスト： 対象拡張子を追加または削除します。

以上の設定を行った上で、「RSS2.0」形式でRSSフィードを出力すれば、（上記で設定した対象拡張子のファイルがある場合のみ）Podcast用RSSフィードが作成されます。

※上記の設定で「Podcast用RSSフィード」になるように設定していても、対象ファイルに（上記で設定した対象拡張子の）音楽ファイルや映像ファイルが含まれていなければ、通常のRSS2.0フィードになります。

Podcast用のRSS2.0フィードに関する注意

iTunesで読み込むためには、文字コードが「 UTF-8 」でなければなりません。 出力時に、文字コードの設定を「 UTF-8 」にするよう注意して下さい。

Podcast用のフィードになるのは「 RSS 2.0 」だけです。「 RSS 1.0 」や「 Atom 0.3 」では、Podcast用のRSSフィードにはなりません。

※この機能は試験実装です。現在のところ、必要最低限の要素（enclosure要素）のみを出力します。ご意見・ご要望は随時受け付けていますので、お気軽にサポートフォーラムなどでお知らせ下さい。

Podcast用RSSフィードの出力に関する説明は以上です。


全自動作成機能を使う - Fumy RSS & Atom Maker マニュアル

Fumy RSS & Atom Maker Ver 0.72β
オンラインヘルプ 2006年03月21日版
概要 → 全自動作成機能を使う

全自動作成機能を使う

全自動作成機能を使えば、ソフトウェアを起動するだけで、自動的に情報を抽出してRSS/Atomフィードを生成し、自動的にFTPでアップロードし、自動的にPingサーバにUpdate Pingを送信させることができます。 その間、ユーザは一切操作をする必要はありません。ただ待っているだけで、すべての作業が完了できる機能です。

全自動作成機能を使う方法は2通りあります。

  1. とりあえずソフトウェアを起動してから、「全自動」メニューを使って、全自動で処理したいプロジェクトファイルを選択する方法。（→説明1）
  2. ソフトウェアを起動するショートカットファイルに設定を書き込んで、ソフトウェアの起動と同時に全自動処理を開始させる方法。（→説明2）

後者の方法なら、「ソフトウェアを起動する」という操作だけで、すべての作業が完了するので、非常にお勧めです。

（１） 「全自動」メニューを使う方法

この方法は、まずソフトウェアを起動しなければなりませんが、ショートカットファイルを修正するなどの複雑な設定は不要で、メニューから項目を選ぶだけなので、簡単に利用できます。

1 | 「自動実行」メニュー | 自動実行機能を、ソフトウェア上から利用する場合は、ツールバー上にある「自動実行」ボタンをクリックします。 ここには、ソフトウェアと同じフォルダに保存されているすべてのプロジェクトファイルのリストが表示されています。 ここから、全自動作業を行いたいプロジェクトをクリックします。 ※項目をクリックすると、すぐに全自動処理が始まります。
2 | 自動実行中のプロセスダイアログ | 自動実行中は、デスクトップの左上に、左図のような進行を示すダイアログが表示されています。 自動実行処理が完了するまで、他の操作はできません。

「サイト設定」で、必要なすべての項目が設定されていれば、「情報抽出」～「Update Pingの送信」まで一気に完了します。
もし、「Update Pingサーバ」が1つも選択されていなければ「FTPでのアップロード」が終了した段階で自動実行は終了します。 もし、「FTP接続」に関する設定が完全に行われていなければ、「RSS/Atomフィードを作成」した段階で自動実行は終了します。 もし、RSS/Atomフィードを生成するための情報も不足していた場合は、自動実行は実行されません。

（２） ショートカットファイルに設定を記述する方法

このソフトウェアを起動するショートカットファイルを作り、そのファイルに直接設定を加えることで、 「ソフトウェアの起動と同時に、全自動処理を開始させる」ことができます。 そう設定するには、次の手順で操作して下さい。

1 | ショートカットを作成して「プロパティ」を開く | まずは、ソフトウェアを起動するショートカットファイルを作ります。 左図では特に名前を変更していませんが、分かりやすい名称を付けておく方が良いでしょう。 ショトカットファイルができたら、そのファイルを右クリックして、コンテキストメニューから「プロパティ」を選択します。（左図の赤枠部分をクリック。） ※左図のコンテキストメニューの内容は、お使いの環境によって異なります。多くの場合、最も下に「プロパティ」という項目があります。
2 | ショートカットの「リンク先」欄にオプションを記述 | ショートカットのプロパティを開いたら、「リンク先」という欄に既に入力されている「ソフトウェアのフルパス」の後に続けて、次の形式でプロジェクトファイルを記述します。（下記は、プロジェクトファイル名が「MYWEB.frp」だった場合の例。） /Auto:MYWEB.frp プログラム名の後には、半角スペースが1つ必要ですので忘れないようにして下さい。 （例） fRssAtom.exe /Auto:MYWEB.frp 「/Auto:」は「/A:」と省略することもできます。 （例） fRssAtom.exe /A:MYWEB.frp ※プロジェクトファイル名はフルパスで記述しても構いません。（ソフトウェアと同じフォルダにない場合は、必ずフルパスで記述しなければなりません。）

この方法なら、ショートカットをダブルクリックしてソフトウェアを起動するだけで、すべての操作を全自動で完了することができます。
また、ツールバーの「全自動」メニューと違って、プロジェクトファイル名をフルパスで記述すれば、どこに保存されているプロジェクトファイルでも全自動処理を行うことができます。

※「リンク先」欄にあるアプリケーションのフルパスが引用符で囲まれている場合は、オプションは、引用符の外側に記述しなければなりませんのでご注意下さい。
[×誤り] "C:\Program Files\rssmaker\fRssAtom.exe /Auto:MYWEB.frp"
[○正解] "C:\Program Files\rssmaker\fRssAtom.exe" /Auto:MYWEB.fpr

3 自動終了するオプション「/Exit」 全自動実行が完了したら、自動的にアプリケーションを終了させるオプションもあります。

/Exit

先ほどの「 /Auto:ファイル名 」オプションの後に、上記の「 /Exit 」オプションを加えておけば、 全自動実行が完了した後、アプリケーションも自動終了するようになります。

（例）
fRssAtom.exe /Auto:MYWEB.frp /Exit

「/Exit」は「/E」と省略することもできます。
（例）
fRssAtom.exe /A:MYWEB.frp /E

※全自動実行処理中にエラーメッセージが表示された場合は、エラーメッセージを閉じるまでアプリケーションは終了はしません。

なお、/Auto オプションや /Exit オプションは、大文字・小文字は区別しません。どちらで書いても大丈夫です。

全自動作成機能に関する説明は以上です。


試験実装機能について - Fumy RSS & Atom Maker マニュアル

Fumy RSS & Atom Maker Ver 0.972β
オンラインヘルプ 2009年06月08日版
概要 → 試験実装機能について

試験実装機能について

今後のバージョンアップを踏まえて、試験的に実装している機能がいくつかあります。

Sitemap XML（サイトマップファイル）の出力機能

Google Sitemapなど、検索エンジン向けのサイトマップファイル（Sitemap XML）を出力する機能があります。

1 | Sitemap XMLファイルを出力するには、メインウインドウが表示されている状態で、 メニューの「データ」→「グリッド操作」→「Sitemap XMLに出力」をクリックします。 （グリッド上で右クリックして「グリッドの内容をSitemap XMLに出力」をクリックしても同じです。）
2 | 出力個数の確認が表示されるので、確認した上で「はい」をクリックすれば、Sitemap XMLファイルが生成されます。

※現行バージョンでは、出力先の指定はできません。ファイル名の指定もできません。Sitemap XMLファイルは、このソフトウェアがインストールされているフォルダ内に sitemap.xml という名称で作成されます。
※Sitemap XMLに含まれる対象となるファイルは、RSSの出力対象となっているファイルです。

上記の仕様や操作方法は、今後のバージョンで変化する可能性があります。

Podcast対応RSSの出力

iTunes（iPod）に対して配信するためのPodcast（ポッドキャスト）用の要素が加わったRSSフィードを出力することができます。
この機能について詳しくは、「Podcast（ポッドキャスト）用RSSを出力するには」ページを参照して下さい。

試験実装機能に関する説明は以上です。